npm WARN deprecated chokidar@2.1.8

Ask New Question
  • npm WARN deprecated chokidar@2.1.8

    I have just installed the Laravel 8 on latest wampserver with PHP 7.3 & Mysql 8. After installing breeze I got many warnings with “npm install” command.

    npm WARN deprecated @types/browserslist@4.15.0: This is a stub types definition. browserslist provides its own type definitions, so you do not need this installed.

    npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.

    npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.

    npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated

    npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated

    npm notice created a lockfile as package-lock.json. You should commit this file.npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules\@types\browser-sync\node_modules\chokidar\node_modules\fsevents):

    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {“os”:”darwin”,”arch”:”any”} (current: {“os”:”win32″,”arch”:”x64″})

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.1 (node_modules\chokidar\node_modules\fsevents):

    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.1: wanted {“os”:”darwin”,”arch”:”any”} (current: {“os”:”win32″,”arch”:”x64″})

    Why the old packages are bundled with the latest laravel? What shoudl I do now? Upgrade them or leave them intact. Please suggest.

    Reply
1 Replies Reply
  • Author
    Replies
  • |  

    I think you have do nothing.

    I had also faced the same issue, but everything is working fine without any problem.

    Reply
Viewing 1 replies (of 1 total)
Reply To: npm WARN deprecated chokidar@2.1.8
Your information: